[Numpy-discussion] [cython-users] errors with numpy 1.5.1

Pauli Virtanen pav@iki...
Tue Mar 8 03:11:55 CST 2011


Tue, 08 Mar 2011 00:12:35 -0800, Robert Bradshaw wrote:
[clip]
> Unfortunately, I don't think anyone's actively working on it right now.
> It's probably a superficial fix for someone who knows NumPy and Cython
> decently well, but I have no idea myself (not having looked that deeply
> into it.) Does anyone know what the backwards incompatible NumPy 1.4 ->
> 1.5 changes were?

No backward incompatible changes, but 1.5 has the new buffer interface 
implemented.

The old buffer interface etc. are still there, but maybe Cython only 
looks at the new buffer interface, and if it does not understand what it 
sees (AFAIK, it only implements a subset of PEP 3118) it fails instead of 
trying the other options?

The errors in the post you linked to fall into two categories:

1) The exact wording of an exception is different "ndarray is not C 
contiguous" vs. "ndarray is not C-contiguous" or "Non-native byte order 
not supported" vs. "Big-endian buffer not supported on little-endian 
compiler", and others which the doctests catch.

2) Cython apparently does/did not recognize the ':' character in 
structured array dtype strings.

	Pauli



More information about the NumPy-Discussion mailing list