[Numpy-discussion] 1.6: branching and release notes

John Salvatier jsalvati@u.washington....
Mon Mar 14 08:11:56 CDT 2011


If they return a tuple of indexes I think 'mulitiindex' sounds quite good.
That is exactly what a multiindex is (
http://en.wikipedia.org/wiki/Multi-index_notation).

On Mon, Mar 14, 2011 at 1:14 AM, Mark Wiebe <mwwiebe@gmail.com> wrote:

> On Sun, Mar 13, 2011 at 11:59 PM, Ralf Gommers <
> ralf.gommers@googlemail.com> wrote:
>
>> On Mon, Mar 14, 2011 at 2:22 PM, Mark Wiebe <mwwiebe@gmail.com> wrote:
>> > On Sun, Mar 13, 2011 at 7:47 PM, Charles R Harris
>> > <charlesr.harris@gmail.com> wrote:
>> >>
>> >> On Sun, Mar 13, 2011 at 8:23 PM, Mark Wiebe <mwwiebe@gmail.com> wrote:
>> >>>
>> >>> On Sun, Mar 13, 2011 at 1:22 AM, Ralf Gommers
>> >>> <ralf.gommers@googlemail.com> wrote:
>> >>>>
>> >>>> Hi all,
>> >>>>
>> >>>> On Tuesday (~2am GMT) I plan to create the 1.6.x branch and tag the
>> >>>> first beta. So please get your last commits for 1.6 in by Monday
>> >>>> evening.
>> >>>>
>> >>>> Also, please review and add to the 1.6.0 release notes. I put in
>> >>>> headers for several items that need a few lines in the notes, I hope
>> >>>> this can be filled in by the authors of those features (Charles:
>> >>>> Legendre polynomials, Pearu: assumed shape arrays, Mark: a bunch of
>> >>>> stuff).
>> >>>
>> >>> I've added a few more things, and made a small change to the iterator
>> >>> construction API that I've discovered is useful, but would be more
>> difficult
>> >>> to do later. The Python exposure of the iterator is renamed from
>> 'newiter'
>> >>> to 'nditer', is that a reasonable name or does anyone have a better
>> >>> suggestion?
>> >>
>> >> I think nditer is fine, certainly better than newiter. I don't see
>> where
>> >> nditer appears in the changes though, the test still uses newiter.
>> >
>> > I didn't rename the files, I can do that too.
>>
>> Hi Mark, I see you just did this, but is there anything else you
>> want/need to do? If it's necessary I can postpone the first beta by a
>> couple of days. Better that than rush things too much and end up with
>> an API you have reservations about.
>>
>
> I've committed one other change I wanted, renaming
> NPY_ITER_NO_INNER_ITERATION to something hopefully a bit more intuitive.
> Nothing else was nagging at me, but it would be great if some people went
> through the iterator documentation to see if all the names fit their
> intuition. We should also come to a consensus on what to call index tuples,
> and rename ravel_coords, NPY_ITER_COORDS, NpyIter_GotoCoords, and
> NpyIter_GetGetCoords based on the chosen name.
>
> -Mark
>
> <snip>
>
>
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion@scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20110314/1a072f91/attachment.html 


More information about the NumPy-Discussion mailing list