[Numpy-discussion] when numpy in Linux apt will be updated? It's still 1.3.0 with many bugs

Mic J michael.cognacc@gmail....
Thu Mar 24 05:51:50 CDT 2011


Isnt [K]Ubuntu updated each 6 month?


2011/3/24 Dmitrey <tmp50@ukr.net>:
> hi,
> when numpy in Linux apt will be updated? It's still 1.3.0 with many bugs

There will always be bugs, but numpy 1.3 is a stable release, unless
there is a bug that affects what your doing right now?

If you find a bug that prevents you from from your specific work,
better report that bug,
if you haven't already.


> I tried to install numpy from PYPI where 1.5.1 seesm to be present, but
> somehow it involves 1.3.0 instead:
>
> $ sudo easy_install numpy
> install_dir /usr/local/lib/python2.6/dist-packages/
> Searching for numpy
> Best match: numpy 1.3.0
> Adding numpy 1.3.0 to easy-install.pth file
>
> only after aptitude remove python-numpy version 1.5.1. is involved by
> easy_install, but it fails:
>
> $ sudo easy_install numpy
> ....
> Adding numpy 1.5.1 to easy-install.pth file
> Installing f2py script to /usr/local/bin
>
> Installed
> /usr/local/lib/python2.6/dist-packages/numpy-1.5.1-py2.6-linux-x86_64.egg
> Processing dependencies for numpy
> Finished processing dependencies for numpy
> /tmp/easy_install-QF6uJM/numpy-1.5.1/numpy/distutils/misc_util.py:251:
> RuntimeWarning: Parent module 'numpy.distutils' not found while handling
> absolute import

I see an *absolute* import, maybe easy_install is different from where
ubuntu expects numpy to be installed?

i think the folder distutils is specific for ubuntu ?


try and remove manually the egg
in /usr/local/lib/python2.6/dist-packages/numpy-1.5.1-py2.6-linux-x86_64.egg

then do

$ sudo easy_install -U numpy

-U is for update, maybe you have to run without -U first?

> Error in atexit._run_exitfuncs:
> Traceback (most recent call last):
>   File "/usr/lib/python2.6/atexit.py", line 24, in _run_exitfuncs
>     func(*targs, **kargs)
>   File "/tmp/easy_install-QF6uJM/numpy-1.5.1/numpy/distutils/misc_util.py",
> line 251, in clean_up_temporary_directory
> ImportError: No module named numpy.distutils
> Error in sys.exitfunc:
> Traceback (most recent call last):
>   File "/usr/lib/python2.6/atexit.py", line 24, in _run_exitfuncs
>     func(*targs, **kargs)
>   File "/tmp/easy_install-QF6uJM/numpy-1.5.1/numpy/distutils/misc_util.py",
> line 251, in clean_up_temporary_directory
> ImportError: No module named numpy.distutils
>
> I have Linux KUBUNTU 10.10
>
> D.

Good question.. ?

easy_install should be distribution non-specific(as far as i know)

see also this thread, even though its old. (late 2009)

http://old.nabble.com/numpy-1.3.0-eggs-with-python2.6-seem-broken-on-osx,-and-linux-td26551531.html

so maybe then download only the egg(with easy_install), then enter the
folder and do sudo python2.6 setup.py install
Dont you have python 2.7 also on ubuntu?


regards mic


More information about the NumPy-Discussion mailing list