Sat Oct 29 21:58:13 CDT 2011
On 10/29/11 5:02 PM, Olivier Delalleau wrote:
> I haven't been following the discussion closely, but wouldn't it be instead:
> a.mask[0:2] = True?
> It's something that I actually find a bit difficult to get right in the
> current numpy.ma <http://numpy.ma> implementation: I would find more
> intuitive to have True for "valid" data, and False for invalid / missing
> / ... I realize how the implementation makes sense (and is appropriate
> given that the name is "mask"), but I just thought I'd point this out...
> even if it's just me ;)
Just a thought: what if this also worked:
as a synonym for a.mask[0:2]=True?
Would that be less confusing, and/or would it be less powerful or
extensible in important ways?
More information about the NumPy-Discussion