[Numpy-discussion] Weird Travis-CI bugs in the release 1.7.x branch

Ondřej Čertík ondrej.certik@gmail....
Tue Dec 4 10:14:31 CST 2012


On Mon, Dec 3, 2012 at 7:10 PM, Nathaniel Smith <njs@pobox.com> wrote:
> On 4 Dec 2012 02:27, "Ondřej Čertík" <ondrej.certik@gmail.com> wrote:
>>
>> Hi,
>>
>> I started to work on the release again and noticed weird failures at
>> Travis-CI:
> […]
>>   File
>> "/home/travis/virtualenv/python2.5/lib/python2.5/site-packages/numpy/core/tests/test_iterator.py",
>
> The problem is that Travis started installing numpy in all python
> virtualenvs by default, and our Travis build script just runs setup.py
> install, which is too dumb to notice that there is a numpy already installed
> and just overwrites it. The file mentioned above doesn't even exist in 1.7,
> it's left over from the 1.6 install.
>
> I did a PR to fix this in master a few days ago, you want to back port that.
> (Sorry for lack of link, I'm on my phone.)

Thanks! I backported it in:

https://github.com/numpy/numpy/pull/2786

Nice, I was not aware of the fact that "pip install ." fixes this
problem with setup.py ---
I've burned myself with this so many times already and I always forget
about this bug.

>
>> P.S. My thesis was finally approved by the grad school today,
>> doing some final changes took more time than expected, but
>> I think that I am done now.
>
> Congratulations Dr. Čertík!

Thanks. I am glad it's over.

Ondrej


More information about the NumPy-Discussion mailing list