[Numpy-discussion] Proposal to drop python 2.4 support in numpy 1.8

Bradley M. Froehle brad.froehle@gmail....
Thu Dec 13 11:12:38 CST 2012


Targeting >= 2.6 would be preferable to me.  Several other packages including IPython, support only Python >= 2.6, >= 3.2.

This change would help me from accidentally writing Python syntax which is allowable in 2.6 & 2.7 (but not in 2.4 or 2.5).

Compiling a newer Python interpreter isn't very hard… probably about as difficult as installing NumPy.

-Brad  


On Thursday, December 13, 2012 at 9:03 AM, Skipper Seabold wrote:

> On Thu, Dec 13, 2012 at 12:00 PM, David Cournapeau <cournape@gmail.com (mailto:cournape@gmail.com)> wrote:
> <snip>
> > I would even go as far as dropping 2.5 as well then (RHEL 6
> > uses python 2.6).
>  
> +1




More information about the NumPy-Discussion mailing list