[Numpy-discussion] Proposal to drop python 2.4 support in numpy 1.8

Jonathan T. Niehof jniehof@lanl....
Thu Dec 13 11:39:29 CST 2012


On 12/13/2012 09:39 AM, Benjamin Root wrote:
> As a point of reference, python 2.4 is on RH5/CentOS5. While RH6 is the
> current version, there are still enterprises that are using version 5.
> Of course, at this point, one really should be working on a migration
> plan and shouldn't be doing new development on those machines...

FWIW this RHEL5* shop uses a local install of 2.6 rather than dealing 
with 2.4. Happy with dropping 2.4 support. Bonus from dropping 2.5: it's 
pretty easy to support a 2.6/3.x combined codebase without relying on 2to3.

(*Not the same as RH5, from days of yore...)

-- 
Jonathan Niehof
ISR-3 Space Data Systems
Los Alamos National Laboratory
MS-D466
Los Alamos, NM 87545

Phone: 505-667-9595
email: jniehof@lanl.gov

Correspondence /
Technical data or Software Publicly Available


More information about the NumPy-Discussion mailing list