[Numpy-discussion] Proposal to drop python 2.4 support in numpy 1.8

Ralf Gommers ralf.gommers@gmail....
Thu Dec 13 14:17:49 CST 2012


On Thu, Dec 13, 2012 at 6:36 PM, Charles R Harris <charlesr.harris@gmail.com
> wrote:

>
>
> On Thu, Dec 13, 2012 at 10:12 AM, Bradley M. Froehle <
> brad.froehle@gmail.com> wrote:
>
>> Targeting >= 2.6 would be preferable to me.  Several other packages
>> including IPython, support only Python >= 2.6, >= 3.2.
>>
>> This change would help me from accidentally writing Python syntax which
>> is allowable in 2.6 & 2.7 (but not in 2.4 or 2.5).
>>
>> Compiling a newer Python interpreter isn't very hard… probably about as
>> difficult as installing NumPy.
>>
>> -Brad
>>
>>
>> On Thursday, December 13, 2012 at 9:03 AM, Skipper Seabold wrote:
>>
>> > On Thu, Dec 13, 2012 at 12:00 PM, David Cournapeau <cournape@gmail.com(mailto:
>> cournape@gmail.com)> wrote:
>> > <snip>
>> > > I would even go as far as dropping 2.5 as well then (RHEL 6
>> > > uses python 2.6).
>> >
>> > +1
>>
>
+1


>
> OK. Dropping support for python 2.4 looks like the majority opinion. I'll
> put up another post for 2.5. Do we need to coordinate with scipy?
>

Not much to coordinate I think. I'll send a message to scipy-dev proposing
to simply follow the Numpy decision.

Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20121213/43203133/attachment-0001.html 


More information about the NumPy-Discussion mailing list