[Numpy-discussion] Support for python 2.4 dropped. Should we drop 2.5 also?

David Cournapeau cournape@gmail....
Thu Dec 13 16:02:25 CST 2012


On Thu, Dec 13, 2012 at 10:07 PM, Chris Barker - NOAA Federal
<chris.barker@noaa.gov> wrote:
>>>> How about dropping support for python 2.5 also?
>
> I"m still dumfounded that people are working on projects where they
> are free to use the latest an greatest numpy, but *have* to use a
> more-than-four-year-old-python:

It happens very easily in corporate environments. Compiling python it
a major headache compared to numpy, not because of python itself, but
because you need to recompile every single extension you're gonna use.

Compiling numpy + its dependencies is at least feasable, but building
things like pygtk when you don't have X11 headers installed is more or
less impossible.

David


More information about the NumPy-Discussion mailing list