[Numpy-discussion] Proposal to drop python 2.4 support in numpy 1.8

Nathaniel Smith njs@pobox....
Fri Dec 14 02:29:39 CST 2012


On 14 Dec 2012 04:14, "Raul Cota" <raul@virtualmaterials.com> wrote:
>
>
> +1 from me
>
> For what is worth, we are just moving forward from Python 2.2 / Numeric
> and are going to 2.6 and it has been rather painful because of the
> several little details of extensions and other subtleties. I believe we
> will settle there for a while. For companies like ours, it is a big
> problem to upgrade versions. There is always this or that hiccup that
> "works great" in a version but not so much in another and we also have
> all sorts of extensions.

Unfortunately (and I know this is a tradeoff), one consequence of this
strategy is that you give up the chance to influence numpy development and
avoid those hiccups in the first place. We try to catch things, but there's
a *lot* more we can do if a bug gets noticed before it makes it into a
final release, or multiple final releases... (This is why 1.7 has been
dragging on - people testing the RCs found a number of places that it broke
there code, so we're fixing numpy instead of them having to fix their code.)

-n
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20121214/c2e5981a/attachment.html 


More information about the NumPy-Discussion mailing list