[Numpy-discussion] Failure in test_iterator.py at Travis

Nathaniel Smith njs@pobox....
Fri Dec 14 11:49:37 CST 2012


The top of the build log has the actual git command they used to check out
the source - it's some clever GitHub thing that gives the same thing as
pressing the green button would iirc. You could copy the commands from the
log to check that out locally though and see what the .travis.tml actually
says. And if it's wrong poke around in the git history to figure out why.

-n
On 14 Dec 2012 17:20, "Ondřej Čertík" <ondrej.certik@gmail.com> wrote:

> On Fri, Dec 14, 2012 at 12:32 AM, Nathaniel Smith <njs@pobox.com> wrote:
> > I only checked this build:
> > https://secure.travis-ci.org/#!/certik/numpy/jobs/3656960
> > But that log clearly shows 'python setup.py install' being used instead
> of
> > 'pip install'. How certain are you that your branch actually has my fix?
>
> Right. So is this one (using "python setup.py install"):
>
> https://travis-ci.org/numpy/numpy/jobs/3330235
>
> No wonder that it fails. Since I rebased this on top of master and the
> master
> has this fix, and so does the 1.7 branch, I can't explain it. I know that
> the master at certik/numpy github does not have that fix (since I didn't
> push in
> there lately), but I don't see how that could matter, unless there is
> a bug at Travis.
> The branches that I created the pull requests from should have that fix.
>
>
> Ondrej
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion@scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20121214/83594f55/attachment.html 


More information about the NumPy-Discussion mailing list