[Numpy-discussion] Compile numpy 1.6.2 with ACML 4.4.0 on CentOS6

Derrick Lin klin938@gmail....
Thu Jul 12 02:44:34 CDT 2012


Hi guys,

I have been trying to compile numpy 1.6.2 with the ACML4.4.0 on our AMD
based cluster.

I mainly followed some guides but most likely outdated like this one:

http://projects.scipy.org/numpy/attachment/ticket/740/acml2.log

I have compiled CBLAS linked with ACML4.4.0 gfortran, and it appears to be
working fine (I ran the supplied built tests).

Then when I compiled numpy 1.6.2, it refused to pick up the CBLAS and ACML
no matter how. It always uses the ATLAS which is installed via OS package
by default.

That legacy guide as well as some very old posts suggested that all magics
happen in site.cfg, which is what I did:

[blas_opt]
libraries = cblas, acml
library_dirs =
/share/ClusterShare/software/centos6/CBLAS/lib/ACML440:/share/ClusterShare/software/noarch/acml4.4.0/gfortran64/lib
include_dirs =
/share/ClusterShare/software/centos6/CBLAS/include:/share/ClusterShare/software/noarch/acml4.4.0/gfortran64/include

[lapack_opt]
libraries = acml
library_dirs = /share/ClusterShare/software/noarch/acml4.4.0/gfortran64/lib
include_dirs =
/share/ClusterShare/software/noarch/acml4.4.0/gfortran64/include

Later I read the official installation guide
http://www.scipy.org/Installing_SciPy/Linux, saying we can export BLAS,
LAPACK to the specified libraries. I tried but didn't work either.

Anyone has done the similar thing successfully?

Thanks in adv.
Derrick
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20120712/7397242c/attachment-0001.html 


More information about the NumPy-Discussion mailing list