[Numpy-discussion] building a numpy egg for centos

Robert Kern robert.kern@gmail....
Tue Jul 24 09:06:22 CDT 2012


On Tue, Jul 24, 2012 at 3:00 PM, Jason Stelzer <jason.stelzer@gmail.com> wrote:
> I'm building numpy 1.6.2 for python 2.5 on centos 5.8.
>
> I ran into a problem where bdist_egg was not working. It seems there's
> a minor bug in numpy/distutils/core.py
>
> Under python 2.5 the check for setuptools does not work, so the bdist
> target for eggs is not available.
>
> I've attached a patch that works around the issue for me. It is my
> understanding that python 2.5 should still be a valid target for
> building this release. If not, ignore this.

This was an explicit design choice. numpy.distutils will never import
setuptools for you even if you have it installed. It will simply
integrate with it if you have run the setup.py script from something
that has setuptools imported, like the setupegg.py script.

What exactly is failing to work under Python 2.5 on your system?
"python setup.py bdist_egg" should never work, but "python setupegg.py
bdist_egg" should.

-- 
Robert Kern


More information about the NumPy-Discussion mailing list