[Numpy-discussion] Dropping support for Python 2.4 in NumPy 1.8

Andreas Hilboll lists@hilboll...
Thu Jun 28 09:54:00 CDT 2012


> Hi Travis,
>
> On Thu, Jun 28, 2012 at 1:25 PM, Travis Oliphant <travis@continuum.io>
> wrote:
>> Hey all,
>>
>> I'd like to propose dropping support for Python 2.4 in NumPy 1.8 (not
>> the 1.7 release).      What does everyone think of that?
>
> I think it would depend on 1.7 state. I am unwilling to drop support
> for 2.4 in 1.8 unless we make 1.7 a LTS, that would be supported up to
> 2014 Q1 (when RHEL5 stops getting security fixes - RHEL 5 is the one
> platform that warrants supporting 2.4 IMO)

+1 for the LTS "requirement". There are many people out there who
cannot/wantnot install their own python just to support a new NumPy
release.

Unless, of course, there's compelling reasons to drop support for Python
2.4 (almost) immediately.



More information about the NumPy-Discussion mailing list