[Numpy-discussion] numpy installation problem?

Benjamin Root ben.root@ou....
Sun Mar 18 10:14:54 CDT 2012


On Sunday, March 18, 2012,  <avalle@famaf.unc.edu.ar> wrote:
> Dear list,
> I am having problems installing matplotlib (from source) and fipy.
> I had installed numpy from source and it is running well:
> :~$ python -c "import numpy; print numpy.__version__"
> 1.6.1
> After being trying to solve this problem on matplotlib list, I was
> recommended to ask numpy list.
> I copy-paste the errors below and forward the mails from matplotlib users.
>
> ...
> ....
> creating /usr/local/lib/python2.7/dist-packages/FiPy-2.1.2-py2.7.egg
> Extracting FiPy-2.1.2-py2.7.egg to /usr/local/lib/python2.7/dist-packages
> FiPy 2.1.2 is already the active version in easy-install.pth
>
> Installed /usr/local/lib/python2.7/dist-packages/FiPy-2.1.2-py2.7.egg
> Processing dependencies for FiPy==2.1.2
> Finished processing dependencies for FiPy==2.1.2
> Traceback (most recent call last):
>  File "setup.py", line 594, in <module>
>    __import__(pkg)
>  File
>
"/usr/local/lib/python2.7/dist-packages/pysparse-1.2_dev224-py2.7-linux-x86_64.egg/pysparse/__init__.py",
> line 6, in <module>
>    from numpy._import_tools import PackageLoader
>  File "/usr/local/lib/python2.7/dist-packages/numpy/__init__.py", line
> 137, in <module>
>    import add_newdocs
>  File "/usr/local/lib/python2.7/dist-packages/numpy/add_newdocs.py", line
> 9, in <module>
>    from numpy.lib import add_newdoc
>  File "/usr/local/lib/python2.7/dist-packages/numpy/lib/__init__.py",
> line 13, in <module>
>    from polynomial import *
>  File "/usr/local/lib/python2.7/dist-packages/numpy/lib/polynomial.py",
> line 11, in <module>
>    import numpy.core.numeric as NX
> AttributeError: 'module' object has no attribute 'core'
> :~/FiPy-2.1.2$
>
>
> :~/matplotlib$ sudo python setup.py install
> basedirlist is: ['/usr/local', '/usr']
>
============================================================================
> BUILDING MATPLOTLIB
>            matplotlib: 1.2.x
>                python: 2.7.2+ (default, Oct  4 2011, 20:06:09)  [GCC
4.6.1]
>              platform: linux2
>
> REQUIRED DEPENDENCIES
>                 numpy: no
>                        * You must install numpy 1.4 or later to build
>                        * matplotlib.
>
>
> I do not understand why matplotlib can not see numpy. Please, see the
> forwarded message. My notebook description:
> Linux 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:27:26 UTC 2011 x86_64
> x86_64 x86_64 GNU/Linux
> Thank in advance for your help
> Regards,
> Lucia
>

Just making sure, where/when did you get your mpl source?  There was a bug
in mpl master for a while that would not parse numpy's development version
number correctly, but it has been fixed since then.

Ben Root
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20120318/53d56ca6/attachment.html 


More information about the NumPy-Discussion mailing list