[Numpy-discussion] Segfault for Numpy 1.4.1 on 64-bit CentOS-5

Tom Aldcroft aldcroft@head.cfa.harvard....
Fri Nov 16 08:19:53 CST 2012


For library compatibility testing I'm trying to use numpy 1.4.1 with Python
2.7.3 on a 64-bit CentOS-5 platform.  I installed a clean Python from
source (basically "./configure --prefix=$prefix ; make install") and then
installed numpy 1.4.1 with "python setup.py install".

The crash message begins with [1]:

*** glibc detected *** /home/aldcroft/vpy/py27_np141/bin/python: free():
invalid next size (fast): 0x000000001a9fcf30 ***
======= Backtrace: =========
/lib64/libc.so.6[0x31a90711df]
/lib64/libc.so.6(cfree+0x4b)[0x31a907163b]
/home/aldcroft/vpy/py27_np141/lib/python2.7/site-packages/numpy/core/multiarray.so[0x2aaab025ebbe]

A problem which seems related is that fancy indexing is failing:

>>> idx = np.array([1])
>>> idx.dtype
dtype('int64')
>>> np.arange(5)[idx]
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
IndexError: index 210453397505 out of bounds 0<=index<5

Does anyone have suggestions for compilation flags or workarounds when
building numpy or Python that might fix this?

Thanks,
Tom

[1] I don't know the exact code that triggered this crash, it's buried in
some units tests.  If it was useful I could dig it out.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20121116/ac612104/attachment.html 


More information about the NumPy-Discussion mailing list