[Numpy-discussion] install numpy 1.6.2 .dmg on macosx 10.7, check for python 2.7

Russell E. Owen rowen@uw....
Thu Nov 29 13:25:25 CST 2012


In article <loom.20121129T124459-287@post.gmane.org>,
 denis <denis-bz-gg@t-online.de> wrote:

> Trying to install numpy 1.6.2 on a mac osx 10.7.4 from this .dmg
>     9323135 numpy-1.6.2-py2.7-python.org-macosx10.3.dmg
> gives
>     "numpy 1.6.2 can't be installed on this disk.
>     numpy requires python.org Python 2.7 to install."
> 
> But python 2.7.3 *is* installed from python.org
>     18761950 python-2.7.3-macosx10.6.dmg
>     and /usr/bin/python is linked as described in
>     http://wolfpaulus.com/journal/mac/installing_python_osx
> python -c 'import sys; print sys.version'
>     2.7.3 (v2.7.3:70274d53c1dd, Apr  9 2012, 20:52:43)
>     [GCC 4.2.1 (Apple Inc. build 5666) (dot 3)]

These are not compatible. You have installed python.org's macosx10.6 
installed (a very reasonable choice). But you must install binary 
packages labelled 10.6, never packages labelled 10.3 (which are only for 
the 10.3 version of python.org's python).

I'm glad you got an error message (however opaque), since if the install 
had succeeded the results would not have worked.

-- Russell

P.S. the difference is:
- 10.6 (which requires MacOS X 10.6 or later) is 64-bit and requires 
intel
- 10.3 (which requires MacOS X 10.3.9 or later) is 32-bit and includes 
PPC support



More information about the NumPy-Discussion mailing list