[Numpy-discussion] copy/deepcopy pull request, Travis build failure

Sebastian Berg sebastian@sipsolutions....
Thu Oct 25 17:15:04 CDT 2012


On Thu, 2012-10-25 at 17:48 -0400, David Warde-Farley wrote:
> I submitted a pull request and one of the Travis builds is failing:
> 
>     https://travis-ci.org/#!/numpy/numpy/jobs/2933551
> 
Don't worry about that failure on Travis... It happens randomly on at
the moment and its unrelated to anything you are doing.
I am not sure though you can change behavior like that since you also
change the default behavior of the `.copy()` method and someone might
rely on that? Maybe making it specific to the copy model would make it
unlikely that anyone relies on the default, it would seem sensible that
copy.copy(array) does basically the same as np.copy(array) and not as
the method .copy, though ideally maybe the differences could be removed
in the long run I guess.

Regards,

Sebastian

> Given my changes,
> 
>     https://github.com/dwf/numpy/commit/4c88fdafc003397d6879f81bf59f68adeeb59f2b
> 
> I don't see how the masked array module (responsible for the failing
> test) could possibly be affected in this manner (RuntimeWarning raised
> by encountering an invalid value in power()).
> 
> Moreover, I cannot reproduce it after setting NPY_SEPARATE_COMPILATION
> on my own machine (whatever that does -- I'm not quite clear).
> 
> Does anyone have any insight into what's going on here? Can anyone
> else reproduce it outside of Travis?
> 
> Thanks,
> David
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion@scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
> 




More information about the NumPy-Discussion mailing list