[Numpy-discussion] Raveling, reshape order keyword unnecessarily confuses index and memory ordering
Thu Apr 4 16:20:41 CDT 2013
On Tue, Apr 2, 2013 at 4:32 AM, Nathaniel Smith <email@example.com> wrote:
> Maybe we should go through and rename "order" to something more descriptive
> in each case, so we'd have
> a.reshape(..., index_order="C")
I'd like to propose this instead:
This fits well with the terms we've been using during the discussion.
It reduces the changes to only one of the two meanings.
Thinking about it, I feel that this would have been considerably
clearer to me as I learned numpy.
More information about the NumPy-Discussion