[Numpy-discussion] Building Numpy 1.6.2 for Python 3.3 on Windows

Christoph Gohlke cgohlke@uci....
Thu Jan 10 11:08:50 CST 2013


On 1/10/2013 8:35 AM, klo wrote:
>> I reported this issue/bug to the mailing list recently as part of
>> a discussion with Ralf which lead to various fixes being made
>> to get NumPy to compile with either mingw32 or MSCV 10.
>
>> http://mail.scipy.org/pipermail/numpy-discussion/2012-November/064454.html
>
>> My workaround is to change the default compiler for Python 3,
>> by creating C:\Python33\Lib\distutils\distutils.cfg containing:
>
>> [build]
>> compiler=mingw32
>
> Thanks, but I have already set C:\Python33\Lib\distutils\distutils.cfg:
>
> ========================================
> [build]
> compiler=mingw32
>
> [build_ext]
> compiler=mingw32
> ========================================
>


Numpy <= 1.6 is not compatible with Python 3.3. Use numpy >= 1.7.0rc1.

Christoph


More information about the NumPy-Discussion mailing list