[Numpy-discussion] Fwd: numpy test fails with "Illegal instruction'

Scott Sinclair scott.sinclair.za@gmail....
Thu Jan 17 08:12:53 CST 2013


On 17 January 2013 12:01, Gerhard Burger <burger.ga@gmail.com> wrote:
> When I run `numpy.test(verbose=10)` it crashes with
>
>     test_polyfit (test_polynomial.TestDocs) ... Illegal instruction
>
> In the FAQ it states that I should provide the following information
> (running Ubuntu 12.04 64bit):
>
>     os.name = 'posix'
>     uname -r = 3.2.0-35-generic
>     sys.platform = 'linux2'
>     sys.version = '2.7.3 (default, Aug  1 2012, 05:14:39) \n[GCC 4.6.3]'
>
> Atlas is not installed (not required for numpy, only for scipy right?)
>
> It fails both when I install numpy 1.6.2 with `pip install numpy` and if I
> install the latest dev version from git.

Very strange. I tried to reproduce this on 64-bit Ubuntu 12.04 (by
removing my ATLAS, BLAS, LAPACK etc..) but couldn't:

$ python -c "import numpy; numpy.test()"
Running unit tests for numpy
NumPy version 1.6.2
NumPy is installed in
/home/scott/.virtualenvs/numpy-tmp/local/lib/python2.7/site-packages/numpy
Python version 2.7.3 (default, Aug  1 2012, 05:14:39) [GCC 4.6.3]
nose version 1.2.1
.........
----------------------------------------------------------------------
Ran 3568 tests in 14.170s

OK (KNOWNFAIL=5, SKIP=5)

$ python -c "import numpy; numpy.show_config()"
blas_info:
  NOT AVAILABLE
lapack_info:
  NOT AVAILABLE
atlas_threads_info:
  NOT AVAILABLE
blas_src_info:
  NOT AVAILABLE
lapack_src_info:
  NOT AVAILABLE
atlas_blas_threads_info:
  NOT AVAILABLE
lapack_opt_info:
  NOT AVAILABLE
blas_opt_info:
  NOT AVAILABLE
atlas_info:
  NOT AVAILABLE
lapack_mkl_info:
  NOT AVAILABLE
blas_mkl_info:
  NOT AVAILABLE
atlas_blas_info:
  NOT AVAILABLE
mkl_info:
  NOT AVAILABLE

Cheers,
Scott


More information about the NumPy-Discussion mailing list