[Numpy-discussion] SVD errors

Robert Kern robert.kern@gmail....
Tue Jun 4 11:31:48 CDT 2013


On Tue, Jun 4, 2013 at 5:18 PM, Amir Mohammadi <183.amir@gmail.com> wrote:

> Hello Everyone,
>
> I am trying to write my own svd function to use the "dgesvd" method from
> lapack, but my problem is that I cannot find the "dgesvd" method from this
> import "from numpy.linalg import lapack_lite".
>
> Do I have to install lapack on my system(Ubuntu 13.04 64-bit)? I want to get
> the same results as MATLAB 2011b which is why I am trying to write a slightly
> different svd function than the function from "numpy.linalg.svd".

numpy does not wrap this LAPACK function. You will have to install
LAPACK yourself and write your own extension module that wraps the
DGESVD subroutine.

scipy also wraps *gesdd, and it would probably be a simple matter of
copy-paste-fix to get it to wrap *gesvd too, since the interfaces are
essentially the same.

https://github.com/scipy/scipy/blob/master/scipy/lib/lapack/flapack_esv.pyf.src#L231

--
Robert Kern


More information about the NumPy-Discussion mailing list