<br><br><div class="gmail_quote">On Sat, Jun 7, 2008 at 9:30 AM, Dan Yamins &lt;<a href="mailto:dyamins@gmail.com">dyamins@gmail.com</a>&gt; wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div class="Ih2E3d"><br>. &nbsp;What I think matters is &quot;no matching architecture in<br></div><div class="gmail_quote"><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div class="Ih2E3d">
<div><div>
&gt; universal wrapper&quot;. Hmmm. I wonder if you and Michael have the same<br>
&gt; versions of OS X?<br>
<br>
</div></div>
</div><div class="Ih2E3d"><div>&gt; And why is dlopen looking for a universal library? One would hope that<br>
&gt; distutils would have taken care of that.</div></div></blockquote><div><br><br>I think you&#39;re right about the &quot;no matching architecture&quot; thing mattering more than the permissions issue.&nbsp; However, somewhere I read that using a &quot;sudo ... install&quot; command could sometimes interfere with distutils.&nbsp;&nbsp; Is that plausible?<br>

<br></div></div></blockquote><div>No, I sudo to install all the time. Usually I do python setup.py build first so I can easily remove the build directory.<br>
<br>
&lt;snip&gt;<br>&nbsp;
<br></div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><div class="gmail_quote"><br><div><div class="Ih2E3d"><br>&gt; What does<br>
&gt;<br>
&gt; file /usr/local/lib/python2.5/site-packages/numpy/core/multiarray.so<br>
&gt;<br>
&gt; do?<br>
&gt;<br><br><br></div>This is telling.&nbsp; I get:<br><br>&nbsp;&nbsp; multiarray.so: Mach-O universal binary with 2 architectures&nbsp; <br>&nbsp;&nbsp; multiarray.so (for architecture i386):&nbsp;&nbsp;&nbsp; Mach-O bundle i386 <br>&nbsp;&nbsp; multiarray.so (for architecture ppc):&nbsp;&nbsp;&nbsp; Mach-O bundle ppc<br>

<br>It seems to my like it&#39;s possible that somehow, I never ended up building numpy as 64-bit in the first place.&nbsp;&nbsp; But I&#39;m basically stumped.&nbsp;&nbsp; <br><br></div></div></blockquote><div><br>A good thing to try is deleting both the build directory and the numpy folder in site-packages just to make sure you are starting with a clean slate. Then try the install again. You should also run which python just to make sure you are using the right python, not that that seems to be the case here. Also, put the build output into a log file like so: $ python setup.py build &amp;&gt; log.txt. Then zip and attach the log to your post so we can get a better idea what is going on. <br>
<br>Chuck <br></div><br></div><br>