<br><br><div class="gmail_quote">On Wed, Mar 3, 2010 at 8:48 AM, Ralf Gommers <span dir="ltr">&lt;<a href="mailto:ralf.gommers@googlemail.com">ralf.gommers@googlemail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">

<br><br><div class="gmail_quote"><div class="im">On Wed, Mar 3, 2010 at 10:34 PM, Patrick Marsh <span dir="ltr">&lt;<a href="mailto:patrickmarshwx@gmail.com" target="_blank">patrickmarshwx@gmail.com</a>&gt;</span> wrote:<br>

<blockquote class="gmail_quote" style="border-left:1px solid rgb(204, 204, 204);margin:0pt 0pt 0pt 0.8ex;padding-left:1ex">
<div class="gmail_quote"><div></div><div>1.  I am still unable to build the windows superpack using pavement.py, even after making sure I have all the necessary dependencies.  However, the good news is that pavement.py now recognizes where the Atlas binaries David provided are located.  The output from &quot;paver bdist_wininst&quot; is located here <a href="http://patricktmarsh.com/numpy/20100302.paveout.txt" target="_blank">http://patricktmarsh.com/numpy/20100302.paveout.txt</a>.</div>





<div><br></div><div>2.  Since I couldn&#39;t get pavement.py to work, I decided to try and build Numpy with sse3 support using &quot;python25 setup.py build -c mingw32 bdist_wininst &gt; buildout.txt&quot;.  (Note, I&#39;ve also done this for building with Python 2.6.)  This works and I&#39;m able to build the windows installer for both Python 2.5 and 2.6.  (The output of the build from Python 2.5 is here <a href="http://patricktmarsh.com/numpy/20100302.buildout.txt" target="_blank">http://patricktmarsh.com/numpy/20100302.buildout.txt</a>.  However, when I try to run the test suite (using &quot;python25 -c &#39;import numpy; print numpy.__version__; numpy.test();&#39; &gt; testout.txt&quot;), Python 2.5 runs, with failures &amp; errors, whereas Python 2.6 freezes and eventually (Python itself) quits.  Since I&#39;m unable to generate the test suite log for Numpy on Python 2.6, I&#39;m working on the (incorrect?) assumption that the freezing when using Python 2.6 corresponds with the failures/errors when using Python 2.5.  The Python 2.5 numpy test suite log is located here: <a href="http://patricktmarsh.com/numpy/20100302.testout.txt" target="_blank">http://patricktmarsh.com/numpy/20100302.testout.txt</a>.  </div>





<div><br></div></div></blockquote></div><div>It fails on importing tempfile, that may be unrelated to numpy. What happens if you run python in a shell and do &quot;import tempfile&quot;? <br></div></div><br></blockquote>

<div><br></div><div>Tempfile imports with no errors with both Python 2.5.4 and Python 2.6.4.</div><div><br></div><div><br></div><div><br></div><div><br></div><div><br></div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">

Cheers,<br><font color="#888888">Ralf<br>
<br>
</font><br>_______________________________________________<br>
NumPy-Discussion mailing list<br>
<a href="mailto:NumPy-Discussion@scipy.org">NumPy-Discussion@scipy.org</a><br>
<a href="http://mail.scipy.org/mailman/listinfo/numpy-discussion" target="_blank">http://mail.scipy.org/mailman/listinfo/numpy-discussion</a><br>
<br></blockquote></div><br><br clear="all"><br>-- <br>Patrick Marsh<br>Ph.D. Student / NSSL Liaison to the HWT<br>School of Meteorology / University of Oklahoma<br>Cooperative Institute for Mesoscale Meteorological Studies<br>

National Severe Storms Laboratory<br><a href="http://www.patricktmarsh.com">http://www.patricktmarsh.com</a><br><br>