[Numpy-svn] r6195 - trunk/numpy/distutils/command

numpy-svn@scip... numpy-svn@scip...
Fri Dec 26 06:16:55 CST 2008


Author: cdavid
Date: 2008-12-26 06:16:45 -0600 (Fri, 26 Dec 2008)
New Revision: 6195

Modified:
   trunk/numpy/distutils/command/scons.py
Log:
Update to handle numscons 0.10.0 and above.

Modified: trunk/numpy/distutils/command/scons.py
===================================================================
--- trunk/numpy/distutils/command/scons.py	2008-12-23 23:43:43 UTC (rev 6194)
+++ trunk/numpy/distutils/command/scons.py	2008-12-26 12:16:45 UTC (rev 6195)
@@ -361,9 +361,13 @@
 
             try:
                 minver = "0.9.3"
-                from numscons import get_version
-                if get_version() < minver:
-                    raise ValueError()
+                try:
+                    # version_info was added in 0.10.0
+                    from numscons import version_info
+                except ImportError:
+                    from numscons import get_version
+                    if get_version() < minver:
+                        raise ValueError()
             except ImportError:
                 raise RuntimeError("You need numscons >= %s to build numpy "\
                                    "with numscons (imported numscons path " \



More information about the Numpy-svn mailing list