[Numpy-svn] r5281 - trunk/numpy/distutils/command

numpy-svn@scip... numpy-svn@scip...
Thu Jun 12 05:56:31 CDT 2008


Author: cdavid
Date: 2008-06-12 05:56:20 -0500 (Thu, 12 Jun 2008)
New Revision: 5281

Modified:
   trunk/numpy/distutils/command/scons.py
Log:
Make sure we are using numscons 0.8.0 or above.

Modified: trunk/numpy/distutils/command/scons.py
===================================================================
--- trunk/numpy/distutils/command/scons.py	2008-06-12 10:05:12 UTC (rev 5280)
+++ trunk/numpy/distutils/command/scons.py	2008-06-12 10:56:20 UTC (rev 5281)
@@ -336,6 +336,16 @@
                 raise RuntimeError("importing numscons failed (error was %s), using " \
                                    "scons within distutils is not possible without "
                                    "this package " % str(e))
+
+            try:
+                from numscons import get_version
+                if get_version() < '0.8.0':
+                    raise ValueError()
+            except ImportError, ValueError:
+                raise RuntimeError("You need numscons >= 0.8.0 to build numpy "\
+                                   "with numscons (imported numscons path " \
+                                   "is %s)." % numscons.__file__)
+                
         else:
             # nothing to do, just leave it here.
             return



More information about the Numpy-svn mailing list