[Numpy-svn] r5989 - trunk/numpy/linalg/tests

numpy-svn@scip... numpy-svn@scip...
Sat Nov 8 01:01:21 CST 2008


Author: cdavid
Date: 2008-11-08 01:01:16 -0600 (Sat, 08 Nov 2008)
New Revision: 5989

Modified:
   trunk/numpy/linalg/tests/test_build.py
Log:
Fix fortrab ABI mismatch test.

Modified: trunk/numpy/linalg/tests/test_build.py
===================================================================
--- trunk/numpy/linalg/tests/test_build.py	2008-11-08 06:51:59 UTC (rev 5988)
+++ trunk/numpy/linalg/tests/test_build.py	2008-11-08 07:01:16 UTC (rev 5989)
@@ -35,13 +35,14 @@
 
         return founds
 
-@dec.skipif(not(sys.platform[:5] == 'linux'), 
-            "Skipping fortran compiler mismatch on non Linux platform")
-def test_f77_mismatch():
-    f = FindDependenciesLdd()
-    deps = f.grep_dependencies(lapack_lite.__file__, 
-                               ['libg2c', 'libgfortran'])
-    if len(deps) > 1:
-        raise AssertionFailure("Both g77 and gfortran runtimes linked in "\
-        "lapack_lite ! This is likely to cause random crashes and wrong "\
-        "results")
+class TestF77Mismatch(TestCase):
+    @dec.skipif(not(sys.platform[:5] == 'linux'), 
+                "Skipping fortran compiler mismatch on non Linux platform")
+    def test_lapack(self):
+        f = FindDependenciesLdd()
+        deps = f.grep_dependencies(lapack_lite.__file__, 
+                                   ['libg2c', 'libgfortran'])
+        self.failIf(len(deps) > 1,
+"""Both g77 and gfortran runtimes linked in lapack_lite ! This is likely to
+cause random crashes and wrong results. See numpy INSTALL.txt for more
+information.""")



More information about the Numpy-svn mailing list