[Numpy-svn] r8690 - trunk/doc/sphinxext

numpy-svn@scip... numpy-svn@scip...
Sat Sep 4 08:08:43 CDT 2010


Author: ptvirtan
Date: 2010-09-04 08:08:43 -0500 (Sat, 04 Sep 2010)
New Revision: 8690

Modified:
   trunk/doc/sphinxext/numpydoc.py
Log:
sphinxext: be explicit about Sphinx version requirements

Modified: trunk/doc/sphinxext/numpydoc.py
===================================================================
--- trunk/doc/sphinxext/numpydoc.py	2010-09-04 13:08:27 UTC (rev 8689)
+++ trunk/doc/sphinxext/numpydoc.py	2010-09-04 13:08:43 UTC (rev 8690)
@@ -16,6 +16,11 @@
 
 """
 
+import sphinx
+
+if sphinx.__version__ < '1.0.1':
+    raise RuntimeError("Sphinx 1.0.1 or newer is required")
+
 import os, re, pydoc
 from docscrape_sphinx import get_doc_object, SphinxDocString
 from sphinx.util.compat import Directive



More information about the Numpy-svn mailing list