[Numpy-svn] [numpy/numpy] 528923: BUG: For compatibility with 1.5, revert to permitt...

noreply@githu... noreply@githu...
Fri Mar 11 14:08:41 CST 2011


Branch: refs/heads/master
Home:   https://github.com/numpy/numpy

Commit: 5289230a0008e27c89c2427873928ceb1a54264f
    https://github.com/numpy/numpy/commit/5289230a0008e27c89c2427873928ceb1a54264f
Author: Mark Wiebe <mwwiebe@gmail.com>
Date:   2011-03-11 (Fri, 11 Mar 2011)

Changed paths:
  M doc/source/reference/c-api.array.rst
  M numpy/core/src/multiarray/ctors.c
  M numpy/core/tests/test_multiarray.py

Log Message:
-----------
BUG: For compatibility with 1.5, revert to permitting limited broadcasting of the assignment output

This change got Travis's -10 veto for 1.6.

An unfortunate consequence of reverting this is that some of the broadcasting
error messages get worse, but they're still no worse than in 1.5.




More information about the Numpy-svn mailing list