[Numpy-svn] [numpy/numpy] 132b37: MAINT: silence DeprecationWarning in np.safe_eval(...

GitHub noreply@github....
Fri Aug 31 07:52:30 CDT 2012


  Branch: refs/heads/master
  Home:   https://github.com/numpy/numpy
  Commit: 132b373a3e50286534df73d07215c11d14d71dda
      https://github.com/numpy/numpy/commit/132b373a3e50286534df73d07215c11d14d71dda
  Author: Ralf Gommers <ralf.gommers@googlemail.com>
  Date:   2012-08-22 (Wed, 22 Aug 2012)

  Changed paths:
    M numpy/lib/utils.py

  Log Message:
  -----------
  MAINT: silence DeprecationWarning in np.safe_eval().

It comes from the Python compiler package, which isn't available on Python 3.x.
We already handle that issue by instead importing the ast module.


  Commit: 68320a10f2e29a70a9a39110263c040aab689147
      https://github.com/numpy/numpy/commit/68320a10f2e29a70a9a39110263c040aab689147
  Author: njsmith <njs@pobox.com>
  Date:   2012-08-31 (Fri, 31 Aug 2012)

  Changed paths:
    M numpy/lib/utils.py

  Log Message:
  -----------
  Merge pull request #390 from rgommers/silence-deprecation-warning

MAINT: silence DeprecationWarning in np.safe_eval().


Compare: https://github.com/numpy/numpy/compare/5c944b9c6915...68320a10f2e2


More information about the Numpy-svn mailing list