[Numpy-svn] [numpy/numpy] 9c9d4b: FIX: use py24-compatible version of virtualenv on ...

GitHub noreply@github....
Tue Sep 11 13:07:16 CDT 2012


  Branch: refs/heads/master
  Home:   https://github.com/numpy/numpy
  Commit: 9c9d4bc6d1c8feb3c268b6421fe01f02eebfd3ab
      https://github.com/numpy/numpy/commit/9c9d4bc6d1c8feb3c268b6421fe01f02eebfd3ab
  Author: Nathaniel J. Smith <njs@pobox.com>
  Date:   2012-09-08 (Sat, 08 Sep 2012)

  Changed paths:
    M .travis-make-py24-virtualenv.sh

  Log Message:
  -----------
  FIX: use py24-compatible version of virtualenv on Travis

Travis recently upgraded to virtualenv 1.8, which has dropped support
for Python 2.4. So, in our Python 2.4 setup script, we need to
explicitly fetch and use virtualenv 1.7. Likewise for pip 1.1.

File imported from the already-fixed version for patsy:
  https://github.com/pydata/patsy/blob/0316d2901f4195db06e8091c15f37d9fe4ad09de/.travis-make-py24-virtualenv.sh


  Commit: b6a1acdd6c989e6e2ab6d68f1b60af030bcccc49
      https://github.com/numpy/numpy/commit/b6a1acdd6c989e6e2ab6d68f1b60af030bcccc49
  Author: njsmith <njs@pobox.com>
  Date:   2012-09-11 (Tue, 11 Sep 2012)

  Changed paths:
    M .travis-make-py24-virtualenv.sh

  Log Message:
  -----------
  Merge pull request #431 from njsmith/fix-travis-py24-build

FIX: use py24-compatible version of virtualenv on Travis


Compare: https://github.com/numpy/numpy/compare/6315567d69fd...b6a1acdd6c98


More information about the Numpy-svn mailing list