[Numpy-tickets] [NumPy] #573: numpy does not build when LDFLAGS are set

NumPy numpy-tickets@scipy....
Fri Dec 7 05:09:28 CST 2007


#573: numpy does not build when LDFLAGS are set
----------------------+-----------------------------------------------------
 Reporter:  bicatali  |        Owner:  somebody
     Type:  defect    |       Status:  new     
 Priority:  normal    |    Milestone:  1.0.5   
Component:  Other     |      Version:  none    
 Severity:  normal    |   Resolution:          
 Keywords:            |  
----------------------+-----------------------------------------------------
Comment (by bicatali):

 it seems that only this command fails, still with numpy-1.0.4:

 --
 error: Command "/usr/bin/gfortran -Wall -Wl,--as-needed
 build/temp.linux-x86_64-2.5/numpy/linalg/lapack_litemodule.o -L/usr/lib
 -L/usr/lib64 -llapack -lblas -lpython2.5 -lgfortran -o
 build/lib.linux-x86_64-2.5/numpy/linalg/lapack_lite.so" failed with exit
 status 1
 --

 in this case, LDFLAGS was set to "-Wl,--as-needed". Adding a -shared
 resolved it. So may be adding "-shared" to already set LDFLAGS in the
 distutils is the only thing to fix.

-- 
Ticket URL: <http://scipy.org/scipy/numpy/ticket/573#comment:2>
NumPy <http://projects.scipy.org/scipy/numpy>
The fundamental package needed for scientific computing with Python.


More information about the Numpy-tickets mailing list