[Numpy-tickets] [NumPy] #935: Failure to build/install numpy

NumPy numpy-tickets@scipy....
Wed Oct 15 09:08:48 CDT 2008


#935: Failure to build/install numpy
------------------------+---------------------------------------------------
 Reporter:  asbjorn     |       Owner:  somebody
     Type:  defect      |      Status:  new     
 Priority:  normal      |   Milestone:          
Component:  numpy.core  |     Version:  1.1.1   
 Severity:  normal      |    Keywords:          
------------------------+---------------------------------------------------
 Hi.

 When running the following command "python setup.py install
 --prefix=/private/afel/.local/, the compiling process begins. After 4
 seconds, I get this error:

 {{{
 building py_modules sources
 building extension "numpy.core.multiarray" sources
   adding 'build/src.linux-x86_64-2.5/numpy/core/include/numpy/config.h' to
 sources.
   adding
 'build/src.linux-x86_64-2.5/numpy/core/include/numpy/numpyconfig.h' to
 sources.
 executing numpy/core/code_generators/generate_array_api.py
   adding
 'build/src.linux-x86_64-2.5/numpy/core/include/numpy/__multiarray_api.h'
 to sources.
 conv_template:> build/src.linux-x86_64-2.5/numpy/core/src/scalartypes.inc
 Traceback (most recent call last):
   File "setup.py", line 96, in <module>
     setup_package()
   File "setup.py", line 89, in setup_package
     configuration=configuration )
   File "/work/afel/python/numpy-1.1.1/numpy/distutils/core.py", line 184,
 in setup
     return old_setup(**new_attr)
   File "/private/afel/.local//lib/python2.5/distutils/core.py", line 151,
 in setup
     dist.run_commands()
   File "/private/afel/.local//lib/python2.5/distutils/dist.py", line 974,
 in run_commands
     self.run_command(cmd)
   File "/private/afel/.local//lib/python2.5/distutils/dist.py", line 994,
 in run_command
     cmd_obj.run()
   File "/work/afel/python/numpy-1.1.1/numpy/distutils/command/build.py",
 line 40, in run
     old_build.run(self)
   File "/private/afel/.local//lib/python2.5/distutils/command/build.py",
 line 112, in run
     self.run_command(cmd_name)
   File "/private/afel/.local//lib/python2.5/distutils/cmd.py", line 333,
 in run_command
     self.distribution.run_command(command)
   File "/private/afel/.local//lib/python2.5/distutils/dist.py", line 994,
 in run_command
     cmd_obj.run()
   File
 "/work/afel/python/numpy-1.1.1/numpy/distutils/command/build_src.py", line
 130, in run
     self.build_sources()
   File
 "/work/afel/python/numpy-1.1.1/numpy/distutils/command/build_src.py", line
 147, in build_sources
     self.build_extension_sources(ext)
   File
 "/work/afel/python/numpy-1.1.1/numpy/distutils/command/build_src.py", line
 252, in build_extension_sources
     sources = self.template_sources(sources, ext)
   File
 "/work/afel/python/numpy-1.1.1/numpy/distutils/command/build_src.py", line
 359, in template_sources
     outstr = process_c_file(source)
   File "/work/afel/python/numpy-1.1.1/numpy/distutils/conv_template.py",
 line 252, in process_file
     code = process_str(''.join(lines))
   File "/work/afel/python/numpy-1.1.1/numpy/distutils/conv_template.py",
 line 222, in process_str
     code.extend(parse_string(astr, global_names, 0, 1))
   File "/work/afel/python/numpy-1.1.1/numpy/distutils/conv_template.py",
 line 210, in parse_string
     newcode = parse_string(text, newenv, newlevel, newline)
   File "/work/afel/python/numpy-1.1.1/numpy/distutils/conv_template.py",
 line 216, in parse_string
     code.append(replace_re.sub(replace, astr))
   File "/work/afel/python/numpy-1.1.1/numpy/distutils/conv_template.py",
 line 187, in replace
     raise KeyError, msg
 KeyError: "#line 558\n: 'form'"
 }}}

 I've tried with both the numpy-1.1.0 and numpy-1.2.0, both gives the same
 output.
 Does anyone have any idea regarding what causes this error?

-- 
Ticket URL: <http://scipy.org/scipy/numpy/ticket/935>
NumPy <http://projects.scipy.org/scipy/numpy>
The fundamental package needed for scientific computing with Python.


More information about the Numpy-tickets mailing list