[NumPy-Tickets] [NumPy] #2013: f2py is not proper translated by 2to3 in linux 64 on python3.2

NumPy Trac numpy-tickets@scipy....
Mon Jan 9 08:31:39 CST 2012


#2013: f2py is not proper translated by 2to3 in linux 64 on python3.2
----------------------------------+-----------------------------------------
 Reporter:  thelen_ben@…          |       Owner:  pearu      
     Type:  enhancement           |      Status:  new        
 Priority:  normal                |   Milestone:  Unscheduled
Component:  numpy.f2py            |     Version:  1.6.1      
 Keywords:                        |  
----------------------------------+-----------------------------------------
 I'm running on Ubuntu 11.10-64 and have installed python3.2 and numpy
 1.6.1 by "$ python3.2 setup.py install" All seems to have installed
 properly and is fully working.

 but if I run f2py2e it will produce various errors caused by 2to3
 translation. See appended file

 I guessed this is caused by numpy for linux only supporting python version
 2.x

 Any updates for numpy release for linux python 3.x?

 Thanks,

-- 
Ticket URL: <http://projects.scipy.org/numpy/ticket/2013>
NumPy <http://projects.scipy.org/numpy>
My example project


More information about the NumPy-Tickets mailing list