[SciPy-dev] Installed on FreeBSD, but no FFT gives errors

Jochen Küpper jochen at jochen-kuepper.de
Fri Nov 9 20:14:42 CST 2001


On Fri, 9 Nov 2001 12:50:38 -0800 Robert Lytle wrote:

Robert> I finally last night installed my hacked SciPy on FreeBSD.  

Nice.

Robert> I couldn't include the FFTW part because the FreeBSD fftw port
Robert> has different libararies than Linux evidently.  

That's not exactly true. Different library *names*. And not compared
to Linux, but compared to "what scipy assumes to be the FFTW
installation". 

I just mad a whole bunch of soft-links in /usr/local/lib to represent
the following (from scipy/setup.py):
,----
|     # FFTW (requires FFTW libraries to be previously installed)
|     double_libraries = ['fftw_threads','rfftw_threads','fftw','rfftw']
|     float_libraries = map(lambda x: 's'+x,double_libraries)
`----
That is, you need libfftw_threads.so, librfftw_threads.so, libfftw.so,
librfftw.so plus the according set of 's'-libraries. I guess it is
obvious what these should link to (depends on what you have:).

In the long run this has to be replaced by some detection scheme what
the FFTW-libs are named on the local system, I'd say.

Greetings,
Jochen
-- 
Einigkeit und Recht und Freiheit                http://www.Jochen-Kuepper.de
    Liberté, Égalité, Fraternité                GnuPG key: 44BCCD8E
        Sex, drugs and rock-n-roll




More information about the Scipy-dev mailing list