[SciPy-dev] Backwards compatibility for weave

Pearu Peterson pearu at cens.ioc.ee
Tue Apr 23 07:35:40 CDT 2002


On Tue, 23 Apr 2002, David O'Gwynn wrote:

> In trying to use weave on the system where I work, I found that it will
> not work with Python2.0. Namely because of the use of the sys._getframe
> method. There might be other compatibility issues as well.
> 
> Is there any kind of workaround for backwards compatibility?

For the getframe issue there is a workaround. Look at the get_frame
function in

  scipy_distutils/misc_utils.py

and in principle weave could use it. I don't know about other (if any)
compatibility issues, though.

Pearu




More information about the Scipy-dev mailing list