[SciPy-dev] Python 2.0 support

Pearu Peterson pearu at cens.ioc.ee
Sat Feb 23 04:48:53 CST 2002


Question:
	To we want to support Python 2.0?

Here are the issues that need to be solved for Python 2.0 support:
1) distutils must be >= 1.0.2
2) inspect module (that is not a part of Python 2.0) is used in the
following places:
	helpmod.py
	weave/catalog.py
3) Python 2.0 installation script does not build zlib automatically. zlib
is used in dumb_shelve.py
4) Python 2.0 comes without unittest, so it must be installed manually.
5) Various scipy tests fails with

TypeError: Comparison of multiarray objects other than rank-0 arrays is
not implemented.

(using Numeric 20.3).
6) sys._getframe is used in
   weave/inline_tools.py
and so that try:..except:.. construct is needed to get frames.

Pearu




More information about the Scipy-dev mailing list