[SciPy-dev] Python 2.0 support

Fernando Perez fperez at pizero.colorado.edu
Sat Feb 23 12:53:35 CST 2002


On Sat, 23 Feb 2002, Pearu Peterson wrote:
> Question:
> 	To we want to support Python 2.0?
> 
> 5) Various scipy tests fails with
> 
> TypeError: Comparison of multiarray objects other than rank-0 arrays is
> not implemented.
> 
> (using Numeric 20.3).
> 6) sys._getframe is used in
>    weave/inline_tools.py
> and so that try:..except:.. construct is needed to get frames.

The others aren't so bad, but these last 2 are killers (esp. 5). The moment
one routine in scipy uses a<b where a and b are NumPy arrays, we're toast.
Putting Python version checks inside numerical code to enable various
workarounds souds quite kludgy to me.

Eric could wourd around 6, but it would be ugly I think. One way to do it is
to trigger an exception deliberately and catch it to get the stack and then
analyze it by hand. But I'm sure he has better things to do with his time
than write that kind of ugly hack for an old version which has other
problems anyway.

Just my 0.02 centavos (which if you know the exchange rate of the Colombian
peso, is *really* nothing).

Cheers,

f.




More information about the Scipy-dev mailing list