[SciPy-dev] Python 2.0 support

eric eric at scipy.org
Sat Feb 23 12:42:27 CST 2002


Hey Pearu,

We started SciPy development with the idea that it would support Python 2.1
forward.  If someone really needs 2.0 support, then we could look at accepting
the patches.  However, there are so many other things to work on that I don't
see it as a priority.  With a project that is so young, it seems like "planning
the future" is a better use of time.

Most of the things on your list are small, but taken together, they'ed be pain
to drag along.  Also (5) *is* a major feature that I'm not sure I'm willing to
do without while developing SciPy functions.

I'm interested in other peoples opinions.

eric

----- Original Message -----
From: "Pearu Peterson" <pearu at cens.ioc.ee>
To: <scipy-dev at scipy.org>
Sent: Saturday, February 23, 2002 5:48 AM
Subject: [SciPy-dev] Python 2.0 support


>
> Question:
> To we want to support Python 2.0?
>
> Here are the issues that need to be solved for Python 2.0 support:
> 1) distutils must be >= 1.0.2
> 2) inspect module (that is not a part of Python 2.0) is used in the
> following places:
> helpmod.py
> weave/catalog.py
> 3) Python 2.0 installation script does not build zlib automatically. zlib
> is used in dumb_shelve.py
> 4) Python 2.0 comes without unittest, so it must be installed manually.
> 5) Various scipy tests fails with
>
> TypeError: Comparison of multiarray objects other than rank-0 arrays is
> not implemented.
>
> (using Numeric 20.3).
> 6) sys._getframe is used in
>    weave/inline_tools.py
> and so that try:..except:.. construct is needed to get frames.
>
> Pearu
>
> _______________________________________________
> Scipy-dev mailing list
> Scipy-dev at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-dev
>





More information about the Scipy-dev mailing list