[SciPy-dev] Install fails on Solaris 5.7

Tom Loredo loredo at astrosun.astro.cornell.edu
Fri Jun 28 16:18:30 CDT 2002


Hi folks-

Just downloaded the latest snapshot:  SciPy-0.2.0_alpha_103.3567.
The install chugs along fine until it reaches fastumath:

scipy_base.fastumath fastumath needs fortran libraries 0 0
building 'scipy_base.fastumath' extension
gcc -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -fPIC -I/home/laplace/include/python2.2 -c /home/laplace/src/python/SciPy-0.2.0_alpha_103.3567/scipy_base/fastumathmodule.c -o build/temp.solaris-2.7-sun4u-2.2/fastumathmodule.o
/home/laplace/src/python/SciPy-0.2.0_alpha_103.3567/scipy_base/fastumathmodule.c:24:36: fastumath_nounsigned.inc: No such file or directory
/home/laplace/include/python2.2/Numeric/arrayobject.h:275: warning: `PyArray_API' defined but not used
/home/laplace/include/python2.2/Numeric/ufuncobject.h:131: warning: `PyUFunc_API' defined but not used
error: command 'gcc' failed with exit status 1


I can't find any .inc files anywhere in the snapshot; I don't know if
that's what's causing the failure or not.  Any hints?

Thanks,
Tom



More information about the Scipy-dev mailing list