[SciPy-dev] Mandrake 9.0

Travis Oliphant oliphant.travis at ieee.org
Tue Nov 5 17:52:09 CST 2002


On Mon, 2002-11-04 at 18:27, Fernando Perez wrote:
> 
> I (for one) would appreciate if you could post when you get full success 
> with Mandrake 9.0. I've been contemplating an upgrade but I don't want to 
> break weave, which I need to _just work_.

I'm only getting one error with weave right now on Mandrake 9.0 (the
other errors were due to permission problems when running as a single
user).

Here's the error I'm getting (i.e. if you don't use what's being tested
then you could still be O.K.)

/usr/lib/python2.2/site-packages/weave/blitz-20001213/blitz/ops.h:220:
no match for `std::complex<float>& / double&' operator

ERROR: result[1:-1,1:-1] = (b[1:-1,1:-1] + b[2:,1:-1] + b[:-2,1:-1]
----------------------------------------------------------------------
Traceback (most recent call last):
  File
"/usr/lib/python2.2/site-packages/weave/tests/test_blitz_tools.py", line
150, in check_5point_avg_2d
    self.generic_2d(expr)
....
....
....


(I've deleted quite a bit of the output.  I think I've included the
relevant gcc error). 

-Travis O.





More information about the Scipy-dev mailing list