[SciPy-dev] Chaco's setup

Andre Alves dmp2000 at mail.ru
Thu Apr 17 02:20:41 CDT 2003


                                    Hi, Mr. E. Jones,
my attempt to install CHACO  from the source chaco-0.1.0_alpha_32.708.zip
was failed, because SETUP need FREETYPE2 and GZIP, absents in the package.
After including needed  from
     (http://sourceforge.net/project/showfiles.php?group_id=23617,
        freetype-2.1.2-src.zip and gzip-1.2.4-src.zip )
I was getting this message

       >>> __file__= D:\chaco-0.1.0_alpha_32.708\scipy_base\__init__.pyc
       running build_ext
       building '_ft' extension
      Traceback (most recent call last):
      File
"C:\PYTHON22\lib\site-packages\Pythonwin\pywin\framework\scriptutils.py",
         line 310, in RunScript
        exec codeObject in __main__.__dict__
      File "D:\3\chaco-0.1.0_alpha_32.708\setup.py", line 92, in ?
         mod.compile( location = build_dir, verbose = 2 )
      File "weave\ext_tools.py", line 332, in compile
         verbose = verbose, **kw)
      File "weave\build_tools.py", line 242, in build_extension
         setup(name = module_name, ext_modules = [ext],verbose=verb)
      File "C:\PYTHON22\lib\distutils\core.py", line 157, in setup
         raise SystemExit, "error: " + str(msg)
      CompileError: error: file
        'D:\3\chaco-0.1.0_alpha_32.708\freetype\freetype2\src\gzip/ftgzip.c'
does
          not exist
     >>>

What versions of FREETYPE2 and GZIP I must include in the chaco's source
to get the success?

The attempt was made under msWindows with Visual C++ , Python222 and
Numeric-23.0
installed.

Best regards, Andre Alves






More information about the Scipy-dev mailing list