[SciPy-dev] Re: [SciPy-user] scipy.cluster -> cluster

eric jones eric at enthought.com
Tue Mar 11 13:46:15 CST 2003


We're in the middle of a lot of changes, so no need to blame anyone.
:-)  Between the CVS changes and the xplt changes, things are just gonna
break for a day or two.  Hopefully we can get things working on as many
platforms as soon as possible. Linux and Windows (MingW) seem to be
mostly working.  I would like OS X and Sun to get working fairly quickly
also.

By the way, I just tried building with cluster enabled on Mac OS X, and
I get:

gcc -L/sw/lib -bundle -bundle_loader /sw/bin/python
build/temp.darwin-6.2-PowerMacintosh-2.2/vq_wrap.o
-Lbuild/temp.darwin-6.2-PowerMacintosh-2.2
-L/sw/lib/gcc-lib/powerpc-apple-darwin6.2/3.1 -L/sw/lib -lc_misc
-lcephes -lrootfind -lg2c -o
build/lib.darwin-6.2-PowerMacintosh-2.2/scipy/cluster/_vq.so
ld: Undefined symbols:
___gxx_personality_v0
error: command 'gcc' failed with exit status 1

So, this looks like the error I was talking about in a previous post.
Changing to:

bash-2.05a$ g++ -L/sw/lib -bundle -bundle_loader /sw/bin/python
build/temp.darwin-6.2-PowerMacintosh-2.2/vq_wrap.o
-Lbuild/temp.darwin-6.2-PowerMacintosh-2.2
-L/sw/lib/gcc-lib/powerpc-apple-darwin6.2/3.1 -L/sw/lib -lc_misc
-lcephes -lrootfind -lg2c -o
build/lib.darwin-6.2-PowerMacintosh-2.2/scipy/cluster/_vq.so

and everything works.  I'll look and see if there is an easy fix.

eric

----------------------------------------------
eric jones                    515 Congress Ave
www.enthought.com             Suite 1614
512 536-1057                  Austin, Tx 78701 


> -----Original Message-----
> From: scipy-dev-admin at scipy.net [mailto:scipy-dev-admin at scipy.net] On
> Behalf Of Travis E. Oliphant
> Sent: Tuesday, March 11, 2003 1:36 PM
> To: scipy-dev at scipy.net
> Subject: Re: [SciPy-dev] Re: [SciPy-user] scipy.cluster -> cluster
> 
> 
> 
> Pearu Peterson wrote:
> 
> >Travis O.,
> >
> >What was the reason that you disabled cluster module in
scipy/setup.py?
> >Can we turn it on again?
> >
> >
> It was not working and I was trying to test something else, so I
didn't
> track down why.
> We can definitely turn it on again and fix whatever the problem was.
> 
> Note, the CVS issues are partly due to the xplt changes and partly due
> to the conversion to the new system, so blame me where
appropriate....:-)
> 
> -Travis
> 
> 
> 
> _______________________________________________
> Scipy-dev mailing list
> Scipy-dev at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-dev





More information about the Scipy-dev mailing list