[SciPy-dev] installation problems with SciPy

Giovanni Samaey Giovanni.Samaey at cs.kuleuven.ac.be
Fri Jun 25 09:07:21 CDT 2004


Hi,

I seem to have some problems installing SciPy.
I installed SciPy from the latest (?) source that I downloaded following
the instructions at
  http://www.scipy.org/documentation/buildscipy.txt

I took advantage of the fact that ATLAS is already installed here under
/usr/lib/3dnow.  I don't have
root access to my system.

The test() routine runs, but gives 15 errors of the type
======================================================================
ERROR: check_sh_legendre (scipy.special.basic.test_basic.test_sh_legendre)
----------------------------------------------------------------------
Traceback (most recent call last):
   File
"/home/giovanni/bin/lib/python2.3/site-packages/scipy/special/tests/test_basic.py", 

line 1806, in check_sh_legendre
     Ps1 = sh_legendre(1)
   File
"/home/giovanni/bin/lib/python2.3/site-packages/scipy/special/orthogonal.py", 

line 593, in sh_legendre
     x,w,mu0 = ps_roots(n,mu=1)
   File
"/home/giovanni/bin/lib/python2.3/site-packages/scipy/special/orthogonal.py", 

line 584, in ps_roots
     return js_roots(n,1.0,1.0,mu=mu)
   File
"/home/giovanni/bin/lib/python2.3/site-packages/scipy/special/orthogonal.py", 

line 205, in js_roots
     val = gen_roots_and_weights(n,an_Js,sbn_Js,mu0)
   File
"/home/giovanni/bin/lib/python2.3/site-packages/scipy/special/orthogonal.py", 

line 121, in gen_roots_and_weights
     eig = get_eig_func()
   File
"/home/giovanni/bin/lib/python2.3/site-packages/scipy/special/orthogonal.py", 

line 91, in get_eig_func
     eig = scipy.linalg.eig
AttributeError: 'module' object has no attribute 'eig'

----------------------------------------------------------------------

Moreover, functions from the packages "integrate" and "linalg" are
simply not found...

I generated the information that is requested by the INSTALL.text file;
it is attached to this mail...

The command
$ python scipy_core/scipy_distutils/command/build_flib.py
could not be executed because for some reason "build_flib.py" is not
present; maybe the info in attachment
might tell why?

If these problems could be solved, I would be thrilled, because SciPy
really looks to a promising tool.
Thanks already in advance,


Best,

Giovanni


-- 
Giovanni Samaey		 	http://www.cs.kuleuven.ac.be/~giovanni/
Katholieke Universiteit Leuven 	      email: giovanni at cs.kuleuven.ac.be
Departement Computerwetenschappen                  phone: +32-16-327081
Celestijnenlaan 200A, B-3001 Heverlee, Belgium       fax: +32-16-327996
Office: A04.36



-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: platform_info.txt
Url: http://projects.scipy.org/pipermail/scipy-dev/attachments/20040625/5161b02f/attachment.txt 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: system_info.txt
Url: http://projects.scipy.org/pipermail/scipy-dev/attachments/20040625/5161b02f/attachment-0001.txt 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: atlas_version.txt
Url: http://projects.scipy.org/pipermail/scipy-dev/attachments/20040625/5161b02f/attachment-0002.txt 


More information about the Scipy-dev mailing list