[SciPy-dev] installation problems with SciPy

Giovanni Samaey Giovanni.Samaey at cs.kuleuven.ac.be
Fri Jun 25 10:47:21 CDT 2004


Thank you for the help.  Putting /usr/lib/3dnow in LD_LIBRARY_PATH made 
the tests run better.

The state has progressed:

Running scipy.test() now gives no errors (on all levels).  The only 
things that go "wrong" now is
two warnings. I don't know if they are worth bothering about:

****************************************************************
WARNING: cblas module is empty
-----------
See scipy/INSTALL.txt for troubleshooting.
Notes:
* If atlas library is not found by scipy/system_info.py,
  then scipy uses fblas instead of cblas.
****************************************************************
****************************************************************
WARNING: clapack module is empty
-----------
See scipy/INSTALL.txt for troubleshooting.
Notes:
* If atlas library is not found by scipy/system_info.py,
  then scipy uses flapack instead of clapack.
****************************************************************

However, import atlas_version still gives an error.  I don't know if I 
should care?

bash-2.05a$ python -c 'import atlas_version'
Traceback (most recent call last):
  File "<string>", line 1, in ?
ImportError: ./atlas_version.so: undefined symbol: ATL_buildinfo

Best, and thanks already!  I would never have found this LD_LIBRARY_PATH 
stuff.

Giovanni

-- 
Giovanni Samaey		 	http://www.cs.kuleuven.ac.be/~giovanni/ 
Katholieke Universiteit Leuven 	      email: giovanni at cs.kuleuven.ac.be 
Departement Computerwetenschappen                  phone: +32-16-327081
Celestijnenlaan 200A, B-3001 Heverlee, Belgium       fax: +32-16-327996
Office: A04.36





More information about the Scipy-dev mailing list