[SciPy-dev] Plan for releasing Scipy 0.3.2

Fernando Perez Fernando.Perez at colorado.edu
Wed Oct 6 16:20:19 CDT 2004


Travis Oliphant schrieb:
> Pearu Peterson wrote:
> 
> 
>>Hi,
>>
>>I think we are ready to make the release: with the recent Scipy from 
>>CVS all tests pass ok on Debian (sid) P4 and AMD MP boxes, Gentoo 
>>Opteron box, and a WinNT box.
>>
>>If you think that there are some important bugs to be fixed, you still 
>>got
>>about 12 hours. I plan to tag Scipy CVS tree tomorrow morning 
>>(Estonian time), create tar-balls, etc. See
>>
>>  http://www.scipy.org/development/releasescipy.txt
>>
>>for relevant tasks.
>>
>>Please, let me know if there is any reason that I should hold on for 
>>tagging CVS tree.

I worry that gui_thread is really not ready for public consumption:

planck[pylab]> cd  /usr/share/doc/wxPythonGTK2-2.4.2.4/demo/
planck[demo]> ip
Python 2.3.3 (#1, May  7 2004, 10:31:40)
Type "copyright", "credits" or "license" for more information.

IPython 0.6.4.rc1 -- An enhanced Interactive Python.
?       -> Introduction to IPython's features.
%magic  -> Information about IPython's 'magic' % functions.
help    -> Python's own help system.
object? -> Details about 'object'. ?object also works, ?? prints more.

In [1]: import gui_thread

In [2]: gui_thread.start()

In [3]: import Main

In [4]: d = Main.wxPythonDemo(None,-1, 'a')
Segmentation fault

Prabhu is getting very good results with wxpython 2.5, but it seems that for 
2.4 there are serious problems still.  I've been running several small tests 
which he has suggested, but with no positive results yet.

Considering that this is on an up-to-date Fedora 2 install, perhaps gui_thread 
  should be disabled for WxPython 2.4.  Printing a warning and telling users 
that gui_thread only supports 2.5 would be better than segfaulting :)

Best,

f




More information about the Scipy-dev mailing list