[SciPy-dev] Re: Plan for releasing Scipy 0.3.2

Berthold Höllmann bhoel at web.de
Wed Oct 6 16:34:36 CDT 2004


Travis Oliphant <oliphant at ee.byu.edu> writes:

> Berthold Höllmann wrote:
>
>>Pearu Peterson <pearu at scipy.org> writes:
>>
>>
>>
>>
>>Testing the actual CVS on a SuSE 9.0 with gcc 3.4.2 I get
>>
>>
>>
>>>python -c "import scipy ; scipy.test()"/usr/local/lib/python2.4/whrandom.py:38: DeprecationWarning: the whrandom module is deprecated; please use the random module
>>>
>>>
>>  DeprecationWarning)
>>   !! No test file 'test_Mplot.py' found for <module 'scipy.xplt.Mplot' from '...-packages/scipy/xplt/Mplot.pyc'>
>>(lots of "!! No test..." and test output)
>>.Testing weibull_min
>>.........
>>======================================================================
>>FAIL: check_basic (scipy.stats.morestats.test_morestats.test_shapiro)
>>----------------------------------------------------------------------
>>Traceback (most recent call last):
>>  File
>> "/usr/local/lib/python2.4/site-packages/scipy/stats/tests/test_morestats.py",
>> line 40, in check_basic
>>    assert_almost_equal(pw,0.52459925413131714,3)
>>  File "/usr/local/lib/python2.4/site-packages/scipy_test/testing.py", line 606, in a
>>ssert_almost_equal
>>    assert round(abs(desired - actual),decimal) == 0, msg
>> AssertionError: Items are not equal:
>>DESIRED: 0.52459925413131714
>>ACTUAL: 1.0
>>
>>----------------------------------------------------------------------
>>Ran 972 tests in 9.784s
>>
>>
>
> Do you get this error consistently or just once in a while?

I get it twice for two tries. Is this consistently enough? Also the

/usr/local/lib/python2.4/whrandom.py:38: DeprecationWarning: the whrandom module is deprecated; please use the random module

comes everytime I run the tests;-)

Regards
Berthold
-- 
bhoel at web.de / http://starship.python.net/crew/bhoel/




More information about the Scipy-dev mailing list