[SciPy-dev] Problems with Scipy and Fedora Core 4

Nils Wagner nwagner at mecha.uni-stuttgart.de
Wed Aug 17 15:16:33 CDT 2005


On Wed, 17 Aug 2005 12:49:11 -0700 (PDT)
  Greg Novak <novak at ucolick.org> wrote:
> I'm having trouble getting Scipy to run on Fedora Core 
>4.  The latest release (0.3.2) fails to compile with 
>errors in the source, probably related to the switch to 
>GCC 4.0.  I'm not summarizing them here because the 
>problems don't exist in the Subversion code.
> 
> After checking out the latest code from svn, Scipy 
>compiles but I get the following error:
> ImportError: 
>/usr/lib/python2.4/site-packages/scipy/linalg/clapack.so: 
>undefined symbol: clapack_sgesv
> 
Maybe you use an incomplete liblapack.
http://math-atlas.sourceforge.net/errata.html#completelp

Nils

> I'm using Fedora Cora 4, with RPMS blas-3.0-29, 
>lapack-3.0-29, and atlas-3.6.0-0.fdr.2 installed.  I've 
>also installed compat-gcc-33-g77 to get g77 and libg2c.a. 
> This... ahem... would seem to have the effect of mixing 
>GCC 3.3 and 4.0 code, which strikes me as dicey at best. 
> Are my worries justified?
> 
> I've attached a complete traceback and the output of 
>scipy_distutils/system_info.py.  Any tips are 
>appreciated, including (if necessary) "It doesn't work 
>right now."
> 
> Thanks,
> Greg
  




More information about the Scipy-dev mailing list