[SciPy-dev] updated Blitz++ to 0.9

Fernando Perez Fernando.Perez at colorado.edu
Tue Nov 1 16:14:08 CST 2005


David M. Cooke wrote:
> I've updated Blitz++ for weave to 0.9. It only has a configuration
> file for g++ right now, but it's easy to add other compilers if
> someone one wishs. To do so,

Did you commit this?  Just this morning I was doing some ubuntu work (gcc 
4.0.2) and had to do the manual overcopy of the weave/blitz/ directory 
(running on old scipy, not the new one).

> It looks like there's nothing special to support gcc 3.3 or 3.4 vs.
> 4.0, which is good.

Yes, Julian Cummings has been working a fair bit to accomodate gcc 4.0.x's 
idiosyncracies regarding the C++ standard.  I can only thank him for that...

Cheers,

f




More information about the Scipy-dev mailing list