[SciPy-dev] 64-bit testing needed

David M. Cooke cookedm at physics.mcmaster.ca
Tue Nov 8 14:10:46 CST 2005


On Nov 8, 2005, at 13:00 , Travis Oliphant wrote:

> I just made some changes to the slice parsing code to allow numbers
> larger than a platform int.  This only affects 64-bit platforms where
> sizeof(intp) != sizeof(int).
>
> I need someone to test the new SVN to make sure I changed all the  
> right
> places.  The changed subroutines are in arrayobject.c
>
> parse_index
> parse_subindex
> slice_GetIndices
> slice_coerce_index
>
> I'm especially interested in warnings on compile.

gcc options: '-pthread -fno-strict-aliasing -DNDEBUG -g -O3 -Wall - 
Wstrict-prototypes -fPIC'
compile options: '-Ibuild/src/scipy/base/src -Iscipy/base/include - 
Ibuild/src/scipy/base -Iscipy/base/src -I/usr/include/python2.4 -c'
gcc: scipy/base/src/multiarraymodule.c
In file included from scipy/base/src/multiarraymodule.c:44:
scipy/base/src/arrayobject.c: In function ‘parse_subindex’:
scipy/base/src/arrayobject.c:1368: warning: passing argument 4 of  
‘slice_GetIndices’ from incompatible pointer type

After fixing this (revision 1447; 'stop' before this warning was  
declared int, not intp),  everything seems to work fine on an Athlon  
64 running Linux.

-- 
|>|\/|<
/------------------------------------------------------------------\
|David M. Cooke              http://arbutus.physics.mcmaster.ca/dmc/
|cookedm at physics.mcmaster.ca




More information about the Scipy-dev mailing list